$re = '/releases\/download\/([\w.]+)\/FreeCAD_(?<build>[\w.]+)-Win/m';
$str = 'https://github.com/FreeCAD/FreeCAD/releases/download/0.19_pre/FreeCAD_0.19.24054-Win-Conda_vc14.x-x86_64.7z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);