const regex = /releases\/download\/([\w.]+)\/FreeCAD_(?<build>[\w.]+)-Win/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('releases\\\/download\\\/([\\w.]+)\\\/FreeCAD_(?<build>[\\w.]+)-Win', 'gm')
const str = `https://github.com/FreeCAD/FreeCAD/releases/download/0.19_pre/FreeCAD_0.19.24054-Win-Conda_vc14.x-x86_64.7z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}