import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "releases\\/download\\/([\\w.]+)\\/FreeCAD_(?<build>[\\w.]+)-Win";
final String string = "https://github.com/FreeCAD/FreeCAD/releases/download/0.19_pre/FreeCAD_0.19.24054-Win-Conda_vc14.x-x86_64.7z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}