# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\/blog\/([a-zA-Z]{1}[a-zA-Z0-9_\/-]+)/\/blog\/blog-post\/dsdsd\//gm;t' <<< "/blog/blog-post-1234/
/blog/blog-post/xsdsf/"