import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)";
final String string = "/blog/blog-post-1234/\n"
+ "/blog/blog-post/xsdsf/";
final String subst = "/blog/blog-post/dsdsd/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}