import Foundation
let pattern = #"^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/blog/blog-post-1234/
/blog/blog-post/xsdsf/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/blog/blog-post/dsdsd/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)