package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)`)
var str = `/blog/blog-post-1234/
/blog/blog-post/xsdsf/`
var substitution = "/blog/blog-post/dsdsd/"
fmt.Println(re.ReplaceAllString(str, substitution))
}