import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^][\"]*\"[^][]*)]";
final String string = "[Strained breathing]\n\n"
+ "[\"Wanna Give My Love\"\n"
+ "by The Sons of Rainier]\n\n"
+ "[Mavrick blows a fart]\n\n"
+ "[\"Hallelujah\"\n"
+ "by The Sons of Rainer]\n\n"
+ "[Victor over the phone]\n\n"
+ "[The Korgi's \"Everybody's\n"
+ "Got To Learn Sometime\"]\n\n"
+ "[Lola chuckles]\n\n"
+ "[\"It's Good\"\n"
+ "by Jack Hammer]\n\n"
+ "[Uno Hype's \"Leave\"]";
final String subst = "{\\1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}