// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[([^]["]*"[^][]*)]"#).unwrap();
let string = "[Strained breathing]
[\"Wanna Give My Love\"
by The Sons of Rainier]
[Mavrick blows a fart]
[\"Hallelujah\"
by The Sons of Rainer]
[Victor over the phone]
[The Korgi's \"Everybody's
Got To Learn Sometime\"]
[Lola chuckles]
[\"It's Good\"
by Jack Hammer]
[Uno Hype's \"Leave\"]";
let substitution = "{\\1}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}