$re = '/\[([^]["]*"[^][]*)]/m';
$str = '[Strained breathing]
["Wanna Give My Love"
by The Sons of Rainier]
[Mavrick blows a fart]
["Hallelujah"
by The Sons of Rainer]
[Victor over the phone]
[The Korgi\'s "Everybody\'s
Got To Learn Sometime"]
[Lola chuckles]
["It\'s Good"
by Jack Hammer]
[Uno Hype\'s "Leave"]';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;