# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([^][\"]*\"[^][]*)]"
test_str = ("[Strained breathing]\n\n"
"[\"Wanna Give My Love\"\n"
"by The Sons of Rainier]\n\n"
"[Mavrick blows a fart]\n\n"
"[\"Hallelujah\"\n"
"by The Sons of Rainer]\n\n"
"[Victor over the phone]\n\n"
"[The Korgi's \"Everybody's\n"
"Got To Learn Sometime\"]\n\n"
"[Lola chuckles]\n\n"
"[\"It's Good\"\n"
"by Jack Hammer]\n\n"
"[Uno Hype's \"Leave\"]")
subst = "{\\1}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.