const regex = /(?<=\S) {2,}(?=\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\S) {2,}(?=\\S)', 'gm')
const str = ` <Directory "THEDIRECTORY">
<LimitExcept GET POST>
deny from all
</LimitExcept>
Options -Indexes -MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);