import re
regex = re.compile(r"(?<=\S) {2,}(?=\S)", flags=re.MULTILINE)
test_str = (" <Directory \"THEDIRECTORY\">\n"
" <LimitExcept GET POST>\n"
" deny from all\n"
" </LimitExcept>\n"
" Options -Indexes -MultiViews\n"
" AllowOverride All\n"
" Order allow,deny\n"
" Allow from all\n"
" </Directory>")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)