use strict;
my $str = ' <Directory "THEDIRECTORY">
<LimitExcept GET POST>
deny from all
</LimitExcept>
Options -Indexes -MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>';
my $regex = qr/(?<=\S) {2,}(?=\S)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";