#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?P<set>(?=^\d+(?:\(|$))(?:\d+)|(?=\d+\)$)(?:\d+))(?:\((?P>set))?"
Local $sString = "123(456)" & @CRLF & _
"123" & @CRLF & _
"abc(123)" & @CRLF & _
"123(abc)" & @CRLF & _
"abc(def)" & @CRLF & _
"1()" & @CRLF & _
"00000(00000)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)