use strict;
my $str = '123(456)
123
abc(123)
123(abc)
abc(def)
1()
00000(00000)';
my $regex = qr/(?P<set>(?=^\d+(?:\(|$))(?:\d+)|(?=\d+\)$)(?:\d+))(?:\((?P>set))?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";