import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<set>(?=^\\d+(?:\\(|$))(?:\\d+)|(?=\\d+\\)$)(?:\\d+))(?:\\((?P>set))?";
final String string = "123(456)\n"
+ "123\n"
+ "abc(123)\n"
+ "123(abc)\n"
+ "abc(def)\n"
+ "1()\n"
+ "00000(00000)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}