$re = '/(?P<set>(?=^\d+(?:\(|$))(?:\d+)|(?=\d+\)$)(?:\d+))(?:\((?P>set))?/m';
$str = '123(456)
123
abc(123)
123(abc)
abc(def)
1()
00000(00000)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;