# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?![^(]*\))/ DESC,/gmi;t' <<< "ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY['f', 'p', 'i', 'a']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3"