using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?![^(]*\))";
string substitution = @" DESC,";
string input = @"ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY['f', 'p', 'i', 'a']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}