re = /,(?![^(]*\))/mi
str = 'ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY[\'f\', \'p\', \'i\', \'a\']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3'
subst = ' DESC,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result