import Foundation
let pattern = #",(?![^(]*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY['f', 'p', 'i', 'a']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" DESC,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)