const regex = /^(\d+).*[\r\n]+(?:\1.*[\r\n]+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+).*[\\r\\n]+(?:\\1.*[\\r\\n]+)*', 'gm')
const str = `ID,text,value
1,some text,5
1,other text,3
1,something,2
2,sample,4
3,john doe,2
3,jane doe,3
4,foo,1
4,bar,2
4,baz,3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}