import re
regex = re.compile(r"^(\d+).*[\r\n]+(?:\1.*[\r\n]+)*", flags=re.MULTILINE)
test_str = ("ID,text,value\n"
"1,some text,5\n"
"1,other text,3\n"
"1,something,2\n"
"2,sample,4\n"
"3,john doe,2\n"
"3,jane doe,3\n"
"4,foo,1\n"
"4,bar,2\n"
"4,baz,3\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")