re = /^(\d+).*[\r\n]+(?:\1.*[\r\n]+)*/m
str = 'ID,text,value
1,some text,5
1,other text,3
1,something,2
2,sample,4
3,john doe,2
3,jane doe,3
4,foo,1
4,bar,2
4,baz,3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end