#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)!\[\[(.*_image[0-9]\.png)\]\]"
Local $sString = "# Abracadabra" & @CRLF & _
"" & @CRLF & _
"![[Abracadabra/Abracadabra_image1.png]]" & @CRLF & _
"![[Abracadabra/Abracadabra_image2.png]]" & @CRLF & _
"" & @CRLF & _
"See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)