using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!\[\[(.*_image[0-9]\.png)\]\]";
string substitution = @"";
string input = @"# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}