const regex = /!\[\[(.*_image[0-9]\.png)\]\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!\\[\\[(.*_image[0-9]\\.png)\\]\\]', 'gm')
const str = `# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);