import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!\\[\\[(.*_image[0-9]\\.png)\\]\\]";
final String string = "# Abracadabra\n\n"
+ "![[Abracadabra/Abracadabra_image1.png]]\n"
+ "![[Abracadabra/Abracadabra_image2.png]]\n\n"
+ "See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}