using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bon\b(?:(?!\bon\b).)*?\bwrote\b";
string input = @"Hi, I saw you on tv yesterday. On Mon 4 P.M Alice wrote";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}