re = /\bon\b(?:(?!\bon\b).)*?\bwrote\b/i
str = 'Hi, I saw you on tv yesterday. On Mon 4 P.M Alice wrote'
# Print the match result
str.match(re) do |match|
puts match.to_s
end