$re = '/\bon\b(?:(?!\bon\b).)*?\bwrote\b/i';
$str = 'Hi, I saw you on tv yesterday. On Mon 4 P.M Alice wrote';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);