const regex = /\bon\b(?:(?!\bon\b).)*?\bwrote\b/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bon\\b(?:(?!\\bon\\b).)*?\\bwrote\\b', 'i')
const str = `Hi, I saw you on tv yesterday. On Mon 4 P.M Alice wrote`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}