using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{3,16}$)[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}([\.](?=[a-z][0-9a-z\-][0-9a-z\-])[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}){0,}$";
string input = @"cryptosharon
cry.pto
-----
cr
sh.ar
-----
cryptosharon9
cry.pto9
c-r.y-p.t-o9
-----
9cryptosharon
9sh.aron
sha.9ron
-----
cry-9-pto-5
s-h-a-r-o-n9
a12.b-3
-----
sh--aron
crptshrn-
otp-.yrc
-----
a12345678901234567
-test-123
.test.123
123.test
tes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}