import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{3,16}$)[a-z]([0-9a-z]|[0-9a-z\\-](?=[0-9a-z])){1,}([\\.](?=[a-z][0-9a-z\\-][0-9a-z\\-])[a-z]([0-9a-z]|[0-9a-z\\-](?=[0-9a-z])){1,}){0,}$";
final String string = "cryptosharon\n"
+ "cry.pto\n"
+ "-----\n"
+ "cr\n"
+ "sh.ar\n"
+ "-----\n"
+ "cryptosharon9\n"
+ "cry.pto9\n"
+ "c-r.y-p.t-o9\n"
+ "-----\n"
+ "9cryptosharon\n"
+ "9sh.aron\n"
+ "sha.9ron\n"
+ "-----\n"
+ "cry-9-pto-5\n"
+ "s-h-a-r-o-n9\n"
+ "a12.b-3\n"
+ "-----\n"
+ "sh--aron\n"
+ "crptshrn-\n"
+ "otp-.yrc\n"
+ "-----\n"
+ "a12345678901234567\n"
+ "-test-123\n"
+ ".test.123\n"
+ "123.test\n"
+ "tes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}