import Foundation
let pattern = #"^(?=.{3,16}$)[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}([\.](?=[a-z][0-9a-z\-][0-9a-z\-])[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}){0,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cryptosharon
cry.pto
-----
cr
sh.ar
-----
cryptosharon9
cry.pto9
c-r.y-p.t-o9
-----
9cryptosharon
9sh.aron
sha.9ron
-----
cry-9-pto-5
s-h-a-r-o-n9
a12.b-3
-----
sh--aron
crptshrn-
otp-.yrc
-----
a12345678901234567
-test-123
.test.123
123.test
tes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)