use strict;
my $str = 'cryptosharon
cry.pto
-----
cr
sh.ar
-----
cryptosharon9
cry.pto9
c-r.y-p.t-o9
-----
9cryptosharon
9sh.aron
sha.9ron
-----
cry-9-pto-5
s-h-a-r-o-n9
a12.b-3
-----
sh--aron
crptshrn-
otp-.yrc
-----
a12345678901234567
-test-123
.test.123
123.test
tes';
my $regex = qr/^(?=.{3,16}$)[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}([\.](?=[a-z][0-9a-z\-][0-9a-z\-])[a-z]([0-9a-z]|[0-9a-z\-](?=[0-9a-z])){1,}){0,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}