package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/.*?\/api\/v\d+\.\d+\/(.+)`)
var str = `/service1/api/v1.0/foo
/service1/api/v1.0/foo/{fooId}
/service1/api/v1.0/foo/{fooId}/boo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}