$re = '/\/.*?\/api\/v\d+\.\d+\/(.+)/m';
$str = '/service1/api/v1.0/foo
/service1/api/v1.0/foo/{fooId}
/service1/api/v1.0/foo/{fooId}/boo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);