re = /\/.*?\/api\/v\d+\.\d+\/(.+)/m
str = '/service1/api/v1.0/foo
/service1/api/v1.0/foo/{fooId}
/service1/api/v1.0/foo/{fooId}/boo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end