const regex = /\/.*?\/api\/v\d+\.\d+\/(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/.*?\\\/api\\\/v\\d+\\.\\d+\\\/(.+)', 'gm')
const str = `/service1/api/v1.0/foo
/service1/api/v1.0/foo/{fooId}
/service1/api/v1.0/foo/{fooId}/boo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}