import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{2}).*?(\\1)";
final String string = "This is a repeated repeated word.zz zz zz\n\n"
+ "How would you find pairs of letters that occur twice in a string using regex with Python?\n\n"
+ "I want to iterate through a list of strings, find the ones that have repeating pairs of letters, and put them into a list. The letters don't need to be the same, the pair just has to repeat, though the letters can be the same.\n\n"
+ "Ex:\n"
+ "this one has xx twice so I want to keep this string:\n"
+ "xxhgfhdeifhjfrikfoixx\n\n"
+ "this one would be kept as well, because hd is repeated: \n"
+ "kwofhdbugktrkdidhdnbk\n\n"
+ "The best I got was to find the pairs: ([a-z][a-z])\\1|([a-z])\\2\n\n"
+ "I need to find which pairs repeat in the string.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}