const regex = /(\w{2}).*?(\1)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{2}).*?(\\1)', 'gi')
const str = `This is a repeated repeated word.zz zz zz
How would you find pairs of letters that occur twice in a string using regex with Python?
I want to iterate through a list of strings, find the ones that have repeating pairs of letters, and put them into a list. The letters don't need to be the same, the pair just has to repeat, though the letters can be the same.
Ex:
this one has xx twice so I want to keep this string:
xxhgfhdeifhjfrikfoixx
this one would be kept as well, because hd is repeated:
kwofhdbugktrkdidhdnbk
The best I got was to find the pairs: ([a-z][a-z])\\1|([a-z])\\2
I need to find which pairs repeat in the string.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}