use strict;
my $str = 'This is a repeated repeated word.zz zz zz
How would you find pairs of letters that occur twice in a string using regex with Python?
I want to iterate through a list of strings, find the ones that have repeating pairs of letters, and put them into a list. The letters don\'t need to be the same, the pair just has to repeat, though the letters can be the same.
Ex:
this one has xx twice so I want to keep this string:
xxhgfhdeifhjfrikfoixx
this one would be kept as well, because hd is repeated:
kwofhdbugktrkdidhdnbk
The best I got was to find the pairs: ([a-z][a-z])\\1|([a-z])\\2
I need to find which pairs repeat in the string.';
my $regex = qr/(\w{2}).*?(\1)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}