# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)"/$1inch/;t' <<< "This is \"my string\" 25\" long"