const regex = /(\d)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)"', '')
const str = `This is "my string" 25" long`;
const subst = `$1inch`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);