$re = '/(\d)"/';
$str = 'This is "my string" 25" long';
$subst = "$1inch";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;