using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)""";
string substitution = @"$1inch";
string input = @"This is ""my string"" 25"" long";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}