import re
regex = re.compile(r"(?<!\s)(?<!since)(\s*)1\.0\.0", flags=re.MULTILINE)
test_str = ("/**\n"
" * @since 1.0.0 <--- this shouldn't be matched\n"
" * @package blah blah blah\n"
" * Version: 1.0.0 <--- this should be matched\n"
" */\n\n"
"/**\n"
" * Fired during plugin activation.\n"
" *\n"
" * This class defines all code necessary to run during the plugin's activation.\n"
" *\n"
" * @since 1.0.0 <--- this shouldn't be matched\n"
" * @package blah blah\n"
" * @subpackage blah blah\n"
" * @author blah blah\n"
" */\n\n"
"define( 'PLUGIN_VERSION', '1.0.0' ); // <--- this should be matched\n")
subst = "${1}1.2.3"
result = regex.sub(subst, test_str)
if result:
print(result)