re = /(?<!\s)(?<!since)(\s*)1\.0\.0/m
str = '/**
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah blah
* Version: 1.0.0 <--- this should be matched
*/
/**
* Fired during plugin activation.
*
* This class defines all code necessary to run during the plugin\'s activation.
*
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah
* @subpackage blah blah
* @author blah blah
*/
define( \'PLUGIN_VERSION\', \'1.0.0\' ); // <--- this should be matched
'
subst = '${1}1.2.3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result